欢迎访问招金外汇网 dfminfo.com.cn

飞狐主图指标

2020-11-08 08:02
飞狐主图指标 飞狐主图指标{CZW-G} {CZW-G}   DRAWBKBMP(CLOSE0,'a008'); {p1:3,0,30;p2:6,1,300;p3:18,1,300;p4:250,0,300}   Var1:=(C+L+H)/3; Var2:=eMA(Var1,6); Var3:=eMA(Var2,5); Var4:=eMA(Var3,12); Var5:=eMA(Var4,5); 生命线:eMA(
飞狐主图指标

飞狐主图指标{CZW-G}

股票

{CZW-G}

 

DRAWBKBMP(CLOSE>0,'a008');

{p1:3,0,30;p2:6,1,300;p3:18,1,300;p4:250,0,300}

 

Var1:=(C+L+H)/3;

Var2:=eMA(Var1,6);

Var3:=eMA(Var2,5);

Var4:=eMA(Var3,12);

Var5:=eMA(Var4,5);

生命线:eMA(Var3,30),COLORRED,POINTDOT;

DRAWICON(C>=生命线,生命线,10);

DRAWICON(C<生命线,生命线,11);

a:=HHV(MA((L+H+C)/3,3),3);

b:=llv(MA((L+H+C)/3,3),10);

STICKLINE(BARSCOUNT(C)=SYSPARAM(1),a,a,20,0),Coloryellow,linethick3,shift1;

DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),a,a,3),shift3,colorYELLOW;

STICKLINE(BARSCOUNT(C)=SYSPARAM(1),b,b,20,0),ColorDB3FDD,linethick3,shift1;

DRAWNUMBER(BARSCOUNT(C)=SYSPARAM(1),b,b,3),shift3,ColorDB3FDD;

 

DRAWTEXT(sysparam(2)=BARPOS,c,' '+BLKNAME),COLORccffcc,ALIGN4;//板块

 

a1:=cost(95);

a2:=cost(5);

ly:=(a1-a2)*100/(a1+a2);

drawicon(ly>ref(ly,1), l*0.98,8)ALIGN5;

 

N:=p1;{原码 N:=3;}

A1:=REF(H,N)=HHV(H,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);{高点}

A2:=REF(L,N)=LLV(L,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);{低点}

E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;

L1:=(D2 AND NOT(D1 AND E1<E2));  H2:=D1 AND NOT(D2 AND E1>=E2);

X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));

G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1),LINETHICK0;{过滤后低点}

L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;

X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));

G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1),LINETHICK0;{过滤后高点}

 

///HD:="jgb.HD"(N);LD:="jgb.LD"(N);

R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}

T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}

R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}

T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}

T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}

T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}

R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}

R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}

★压力1:DRAWLINE(S2,H,S1,H,1),Color80FFFF;         

★支撑1:DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick2;

★压力2:DRAWLINE(S3,H,S2,H,1),ColorFF8000;

★支撑2:DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;         

【免责声明】本文仅代表作者本人观点,与招金外汇网无关。招金外汇网对文中陈述、观点判断保持中立,不对所包含内容的准确性、可靠性或完整性提供任何明示或暗示的保证,且不构成任何投资建议,请读者仅作参考,并自行承担全部风险与责任。